summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--debian/control20
-rwxr-xr-xdebian/rules6
3 files changed, 25 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 7b04237..1a67126 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-phat (1.5-1) unstable; urgency=medium
+phat (1.5-1) UNRELEASED; urgency=medium
* Initial release (Closes: #920912)
diff --git a/debian/control b/debian/control
index 2afcd5c..42ada2f 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,12 @@ Maintainer: Gard Spreemann <gspreemann@gmail.com>
Section: math
Priority: optional
Standards-Version: 4.3.0.1
-Build-Depends: cmake, debhelper (>= 12)
+Build-Depends: cmake,
+ debhelper (>= 12),
+ dh-python,
+ python3-all-dev,
+ python3-pybind11,
+ python3-setuptools
Homepage: https://bitbucket.org/phat-code/phat
Vcs-Browser: https://git.nonempty.org/debian-phat
Vcs-Git: https://git.nonempty.org/debian-phat -b debian/sid
@@ -34,4 +39,15 @@ Description: Utilities from the PHAT library
This package contains some standalone utilities built using the PHAT
library, such as persistent homology of a given filtered boundary
matrix.
- \ No newline at end of file
+
+Package: python3-phat
+Section: python
+Architecture: any
+Multi-Arch: same
+Depends: ${misc:Depends}, ${python3:Depends}, ${shlibs:Depends}
+Description: Python 3 interface for the PHAT library
+ PHAT is a header-only C++ library for performing the filtered Z/2Z
+ (co)boundary matrix operations commonly needed when computing
+ (persistent) (co)homology in topological data analysis.
+ .
+ This package contains the library's Python 3 interface.
diff --git a/debian/rules b/debian/rules
index ddd8443..d923eef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,12 @@
#export DH_VERBOSE = 1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export PYBUILD_NAME = phat
+
+# To avoid autodetecting upstream's CMakeFile, which doesn't build the
+# Python extension.
+export PYBUILD_SYSTEM = distutils
%:
dh $@ --buildsystem=cmake --builddirectory=build
+ dh $@ --with python3 --buildsystem=pybuild