summaryrefslogtreecommitdiff
path: root/python/README.rst
diff options
context:
space:
mode:
Diffstat (limited to 'python/README.rst')
-rw-r--r--python/README.rst14
1 files changed, 9 insertions, 5 deletions
diff --git a/python/README.rst b/python/README.rst
index 3fd685d..9f7fe41 100644
--- a/python/README.rst
+++ b/python/README.rst
@@ -48,14 +48,18 @@ Suppose you have checked out the PHAT repository at location $PHAT. Then you can
```
cd $PHAT/python
-pip install .
+ln -s ../include include # (or copy, we just need $PHAT/include to be in the current folder as well)
+
+pip install pybind11
+
+python setup.py install
```
-This will install PHAT for whatever Python installation your `pip` executable is associated with.
-Also note that this will install dependencies (pybind11) as well.
-If you already have pybind11 installed, then `python setup.py install` will most likely work too.
+This will install PHAT for whatever Python installation your `python` executable is associated with.
+Please ensure you use the `pip` that comes from the same directory where your `python` executable lives!
-Currently, the PHAT Python bindings are known to work on Mac OS X with Python 3.5. Other configurations are untested but in progress.
+Currently, the PHAT Python bindings are known to work on Linux with Python 2.7 and Python 3.5.
+Other configurations are untested but in progress.
Please let us know if there is a platform you'd like us to support, we will do so if we can.
Sample usage