summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2015-05-18 15:15:36 +0200
committerMario Mulansky <mario.mulansky@gmx.net>2015-05-18 15:15:36 +0200
commit81fc2c20e7360714f218e9bba729ec4387f59aef (patch)
tree417addf9991f6ed49dbac69c717cab715126a607
parentc8f524db6e1add464aa3596ea46534c21096589e (diff)
set version 0.3
-rw-r--r--Changelog4
-rw-r--r--doc/conf.py4
-rw-r--r--setup.py8
3 files changed, 9 insertions, 7 deletions
diff --git a/Changelog b/Changelog
index 798403e..519dd3b 100644
--- a/Changelog
+++ b/Changelog
@@ -1,4 +1,4 @@
-PySpike v0.2.1:
+PySpike v0.3:
* addition of __version__ attribute
* restructured docs, Readme now only contains basic examples
* performance improvements by introducing specific distance functions
@@ -7,6 +7,8 @@ PySpike v0.2.1:
* new example: performance.py
* consistent treatment of empty spike trains
* new example: profiles.py
+ * additional functionality: pwc and pwl function classes can now return
+ function values at given time(s)
PySpike v0.2:
diff --git a/doc/conf.py b/doc/conf.py
index 9b994c2..8011ea9 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -64,9 +64,9 @@ copyright = u'2014-2015, Mario Mulansky'
# built documents.
#
# The short X.Y version.
-version = '0.2'
+version = '0.3'
# The full version, including alpha/beta/rc tags.
-release = '0.2.0'
+release = '0.3.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index 7902066..d853cdf 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ to compile cython files:
python setup.py build_ext --inplace
-Copyright 2014, Mario Mulansky <mario.mulansky@gmx.net>
+Copyright 2014-2015, Mario Mulansky <mario.mulansky@gmx.net>
Distributed under the BSD License
@@ -49,7 +49,7 @@ elif use_c: # c files are there, compile to binaries
setup(
name='pyspike',
packages=find_packages(exclude=['doc']),
- version='0.1.3',
+ version='0.3.0',
cmdclass=cmdclass,
ext_modules=ext_modules,
include_dirs=[numpy.get_include()],
@@ -59,7 +59,6 @@ train similarity',
author_email='mario.mulanskygmx.net',
license='BSD',
url='https://github.com/mariomulansky/PySpike',
- # download_url='https://github.com/mariomulansky/PySpike/tarball/0.1',
install_requires=['numpy'],
keywords=['data analysis', 'spike', 'neuroscience'], # arbitrary keywords
classifiers=[
@@ -81,7 +80,8 @@ train similarity',
'Programming Language :: Python :: 2.7',
],
package_data={
- 'pyspike': ['cython/cython_add.c', 'cython/cython_profiles.c'],
+ 'pyspike': ['cython/cython_add.c', 'cython/cython_profiles.c',
+ 'cython_distances.c'],
'test': ['Spike_testdata.txt']
}
)