summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2017-10-05 10:42:05 -0700
committerGitHub <noreply@github.com>2017-10-05 10:42:05 -0700
commitd46f5754f79dfcaf5416a836cbda8f5db17738b1 (patch)
tree46047a9cb778db8401fd40eec94cc38d12a9d861
parentecd4b5f0f7e93859c1262593e2c09e1eb6775819 (diff)
parent16040c3fb9f61f7753172f6d67ac7b22c961dcaa (diff)
Merge pull request #28 from mariomulansky/master
Master back into develop
-rw-r--r--Readme.rst17
-rw-r--r--doc/conf.py4
-rw-r--r--setup.py6
3 files changed, 20 insertions, 7 deletions
diff --git a/Readme.rst b/Readme.rst
index 542f4b3..0422dad 100644
--- a/Readme.rst
+++ b/Readme.rst
@@ -7,7 +7,7 @@ PySpike
:target: https://travis-ci.org/mariomulansky/PySpike
PySpike is a Python library for the numerical analysis of spike train similarity.
-Its core functionality is the implementation of the ISI_ and SPIKE_ distance [#]_ [#]_ as well as SPIKE-Synchronization_ [#]_.
+Its core functionality is the implementation of the ISI_\-distance [#]_ and SPIKE_\-distance [#]_ as well as SPIKE-Synchronization_ [#]_.
It provides functions to compute multivariate profiles, distance matrices, as well as averaging and general spike train processing.
All computation intensive parts are implemented in C via cython_ to reach a competitive performance (factor 100-200 over plain Python).
@@ -15,11 +15,18 @@ PySpike provides the same fundamental functionality as the SPIKY_ framework for
All source codes are available on `Github <https://github.com/mariomulansky/PySpike>`_ and are published under the BSD_License_.
+Citing PySpike
+----------------------------
+If you use PySpike in your research, please cite our SoftwareX publication on PySpike:
+ Mario Mulansky, Thomas Kreuz, *PySpike - A Python library for analyzing spike train synchrony*, SoftwareX, (2016), ISSN 2352-7110, http://dx.doi.org/10.1016/j.softx.2016.07.006.
+
+Additionally, depending on the used methods: ISI-distance [1], SPIKE-distance [2] or SPIKE-Synchronization [3], please cite one or more of the following publications:
+
.. [#] Kreuz T, Haas JS, Morelli A, Abarbanel HDI, Politi A, *Measuring spike train synchrony.* J Neurosci Methods 165, 151 (2007) `[pdf] <http://wwwold.fi.isc.cnr.it/users/thomas.kreuz/images/Kreuz_JNeurosciMethods_2007_Spike-Train-Synchrony.pdf>`_
.. [#] Kreuz T, Chicharro D, Houghton C, Andrzejak RG, Mormann F, *Monitoring spike train synchrony.* J Neurophysiol 109, 1457 (2013) `[pdf] <http://wwwold.fi.isc.cnr.it/users/thomas.kreuz/images/Kreuz_JNeurophysiol_2013_SPIKE-distance.pdf>`_
-.. [#] Kreuz T, Mulansky M and Bozanic N, *SPIKY: A graphical user interface for monitoring spike train synchrony*, J Neurophysiol, in press (2015)
+.. [#] Kreuz T, Mulansky M and Bozanic N, *SPIKY: A graphical user interface for monitoring spike train synchrony*, J Neurophysiol, JNeurophysiol 113, 3432 (2015)
Important Changelog
-----------------------------
@@ -31,6 +38,12 @@ This is a breaking change in the function interfaces.
Hence, programs written for older versions of PySpike (0.1.x) will not run with newer versions.
+Upcoming Functionality
+-------------------------
+
+In an upcoming release, new functionality for analyzing Synfire patterns based on the new measures SPIKE-Order and Spike-Train-Order method will become part of the PySpike library.
+The new measures and algorithms are described in `this preprint <https://arxiv.org/abs/1610.07986>`_.
+
Requirements and Installation
-----------------------------
diff --git a/doc/conf.py b/doc/conf.py
index 807dec6..25aa9c9 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -57,7 +57,7 @@ master_doc = 'index'
# General information about the project.
project = u'PySpike'
-copyright = u'2014-2015, Mario Mulansky'
+copyright = u'2014-2017, Mario Mulansky'
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
@@ -66,7 +66,7 @@ copyright = u'2014-2015, Mario Mulansky'
# The short X.Y version.
version = '0.5'
# The full version, including alpha/beta/rc tags.
-release = '0.5.1'
+release = '0.5.3'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index afcfa16..5b9e677 100644
--- a/setup.py
+++ b/setup.py
@@ -62,14 +62,14 @@ elif use_c: # c files are there, compile to binaries
setup(
name='pyspike',
packages=find_packages(exclude=['doc']),
- version='0.5.2',
+ version='0.5.3',
cmdclass=cmdclass,
ext_modules=ext_modules,
include_dirs=[numpy_include()],
description='A Python library for the numerical analysis of spike\
train similarity',
author='Mario Mulansky',
- author_email='mario.mulanskygmx.net',
+ author_email='mario.mulansky@gmx.net',
license='BSD',
url='https://github.com/mariomulansky/PySpike',
install_requires=['numpy'],
@@ -79,7 +79,7 @@ train similarity',
# 3 - Alpha
# 4 - Beta
# 5 - Production/Stable
- 'Development Status :: 3 - Beta',
+ 'Development Status :: 4 - Beta',
# Indicate who your project is intended for
'Intended Audience :: Science/Research',