summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2021-12-29 17:53:33 -0600
committerMario Mulansky <mario.mulansky@gmx.net>2021-12-29 17:53:33 -0600
commitcf421763434059d5fb1e5cc347b0db781116767d (patch)
treed2e7c011461c947abe3b4a2c63025e378fdf5fd9
parenta0053c004ed55e7eb5effd43faa3c0d49cf7c373 (diff)
Add cython to test matrix
-rw-r--r--.github/workflows/python-package.yml9
1 files changed, 6 insertions, 3 deletions
diff --git a/.github/workflows/python-package.yml b/.github/workflows/python-package.yml
index edb25d2..6585af4 100644
--- a/.github/workflows/python-package.yml
+++ b/.github/workflows/python-package.yml
@@ -17,6 +17,7 @@ jobs:
fail-fast: false
matrix:
python-version: ["3.7", "3.8", "3.9", "3.10"]
+ cython: ['python -m pip install -q cython', 'echo "No Cython"']
steps:
- uses: actions/checkout@v2
@@ -32,11 +33,13 @@ jobs:
sudo apt-get install gfortran
python -m pip install --upgrade pip
python -m pip install flake8 pytest nose numpy scipy
- python -m pip install -q cython
if [ -f requirements.txt ]; then pip install -r requirements.txt; fi
+ - name: Install Cython
+ run: |
+ ${{ matrix.cython }}
- name: Install package
run: |
- python setup.py build_ext
+ python setup.py build_ext --inplace
# - name: Lint with flake8
# run: |
# # stop the build if there are Python syntax errors or undefined names
@@ -45,4 +48,4 @@ jobs:
# flake8 . --count --exit-zero --max-complexity=10 --max-line-length=127 --statistics
- name: Test with PyTest
run: |
- python3 -m pytest
+ python -m pytest