summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Changelog6
-rw-r--r--doc/conf.py4
-rw-r--r--setup.py2
3 files changed, 9 insertions, 3 deletions
diff --git a/Changelog b/Changelog
index 519dd3b..2be5e52 100644
--- a/Changelog
+++ b/Changelog
@@ -1,3 +1,9 @@
+PySpike v0.4:
+ * Python 3 support (thanks to Igor Gnatenko)
+ * list interface to SpikeTrain class
+ * disable_backend_warning property
+ * several bugfixes
+
PySpike v0.3:
* addition of __version__ attribute
* restructured docs, Readme now only contains basic examples
diff --git a/doc/conf.py b/doc/conf.py
index 8011ea9..7e13eae 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -64,9 +64,9 @@ copyright = u'2014-2015, Mario Mulansky'
# built documents.
#
# The short X.Y version.
-version = '0.3'
+version = '0.4'
# The full version, including alpha/beta/rc tags.
-release = '0.3.0'
+release = '0.4.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index 62c1951..a1ab122 100644
--- a/setup.py
+++ b/setup.py
@@ -60,7 +60,7 @@ elif use_c: # c files are there, compile to binaries
setup(
name='pyspike',
packages=find_packages(exclude=['doc']),
- version='0.3.0',
+ version='0.4.0',
cmdclass=cmdclass,
ext_modules=ext_modules,
include_dirs=[numpy.get_include()],