summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py30
1 files changed, 22 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 7a4ac56..52bebd9 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ to compile cython files:
python setup.py build_ext --inplace
-Copyright 2014-2016, Mario Mulansky <mario.mulansky@gmx.net>
+Copyright 2014-2017, Mario Mulansky <mario.mulansky@gmx.net>
Distributed under the BSD License
@@ -12,7 +12,6 @@ Distributed under the BSD License
from setuptools import setup, find_packages
from distutils.extension import Extension
import os.path
-import numpy
try:
from Cython.Distutils import build_ext
@@ -21,6 +20,14 @@ except ImportError:
else:
use_cython = True
+
+class numpy_include(object):
+ """Defers import of numpy until install_requires is through"""
+ def __str__(self):
+ import numpy
+ return numpy.get_include()
+
+
if os.path.isfile("pyspike/cython/cython_add.c") and \
os.path.isfile("pyspike/cython/cython_profiles.c") and \
os.path.isfile("pyspike/cython/cython_distances.c") and \
@@ -65,14 +72,14 @@ elif use_c: # c files are there, compile to binaries
setup(
name='pyspike',
packages=find_packages(exclude=['doc']),
- version='0.5.1',
+ version='0.5.3',
cmdclass=cmdclass,
ext_modules=ext_modules,
- include_dirs=[numpy.get_include()],
+ include_dirs=[numpy_include()],
description='A Python library for the numerical analysis of spike\
train similarity',
author='Mario Mulansky',
- author_email='mario.mulanskygmx.net',
+ author_email='mario.mulansky@gmx.net',
license='BSD',
url='https://github.com/mariomulansky/PySpike',
install_requires=['numpy'],
@@ -82,7 +89,7 @@ train similarity',
# 3 - Alpha
# 4 - Beta
# 5 - Production/Stable
- 'Development Status :: 3 - Alpha',
+ 'Development Status :: 4 - Beta',
# Indicate who your project is intended for
'Intended Audience :: Science/Research',
@@ -92,11 +99,18 @@ train similarity',
'License :: OSI Approved :: BSD License',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
- ]
+ 'Programming Language :: Python :: 3.6'
+ ],
+ package_data={
+ 'pyspike': ['cython/cython_add.c', 'cython/cython_profiles.c',
+ 'cython/cython_distances.c',
+ 'cython/cython_directionality.c',
+ 'cython/cython_simulated_annealing.c'],
+ 'test': ['Spike_testdata.txt']
+ }
)