summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2021-11-29 09:12:21 +0100
committerGard Spreemann <gspr@nonempty.org>2021-11-29 09:12:21 +0100
commitddbc9272c0405d467c8e4ab871e16f7c97fd1a06 (patch)
tree306853c25272bf066a6b6e386710606fcf967771
parent4bc16ccec028feb7610c09783c49b01d000be6de (diff)
Correct architecture variablesdebian/0.8.2-2
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules6
2 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 0e8f197..85e741f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+waypipe (0.8.2-2) unstable; urgency=medium
+
+ * Correct typo in architecture variables so as to actually build with
+ SIMD capabilities.
+
+ -- Gard Spreemann <gspr@nonempty.org> Mon, 29 Nov 2021 09:10:58 +0100
+
waypipe (0.8.2-1) unstable; urgency=medium
* New upstream version.
diff --git a/debian/rules b/debian/rules
index 994b9ea..bff520c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,15 +2,15 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
--include /usr/share/dpkg/architecture.mk
+include /usr/share/dpkg/architecture.mk
%:
dh $@
override_dh_auto_configure:
-ifeq ($(DEB_BUILD_HOST), amd64)
+ifeq ($(DEB_HOST_ARCH), amd64)
dh_auto_configure -- -Dwith_avx2=true -Dwith_avx512f=true -Dwith_neon_opts=false -Dwith_sse3=true
-else ifeq ($(DEB_BUILD_HOST), arm64)
+else ifeq ($(DEB_HOST_ARCH), arm64)
dh_auto_configure -- -Dwith_avx2=false -Dwith_avx512f=false -Dwith_neon_opts=true -Dwith_sse3=false
else
dh_auto_configure -- -Dwith_avx2=false -Dwith_avx512f=false -Dwith_neon_opts=false -Dwith_sse3=false