summaryrefslogtreecommitdiff
path: root/wasserstein/example/CMakeLists.txt
diff options
context:
space:
mode:
authorArnur Nigmetov <anigmetov@lbl.gov>2022-04-09 17:33:15 -0700
committerArnur Nigmetov <anigmetov@lbl.gov>2022-04-09 17:33:15 -0700
commit8fbae1d789b3c9d7e9b079284c85489d8dcd7e65 (patch)
treec884ea100a702c7a6cb1cef083168ed59d7e0f31 /wasserstein/example/CMakeLists.txt
parente62d16d7b1c42163de7b21ab74a780c3c1cf8e45 (diff)
Major cleanupupstream/latest
Diffstat (limited to 'wasserstein/example/CMakeLists.txt')
-rw-r--r--wasserstein/example/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/wasserstein/example/CMakeLists.txt b/wasserstein/example/CMakeLists.txt
new file mode 100644
index 0000000..2e2f1f2
--- /dev/null
+++ b/wasserstein/example/CMakeLists.txt
@@ -0,0 +1,21 @@
+add_executable(wasserstein_dist wasserstein_dist.cpp)
+target_link_libraries(wasserstein_dist PUBLIC ${libraries})
+
+add_executable(wasserstein_dist_dipha wasserstein_dist_dipha.cpp)
+target_link_libraries(wasserstein_dist_dipha PUBLIC ${libraries})
+
+# pure geometric version, arbitrary dimension
+add_executable(wasserstein_dist_point_cloud wasserstein_dist_point_cloud.cpp)
+target_link_libraries(wasserstein_dist_point_cloud PUBLIC ${libraries})
+
+if(MSVC)
+ target_compile_options(wasserstein_dist PRIVATE /W4 /WX)
+ target_compile_options(wasserstein_dist_dipha PRIVATE /W4 /WX)
+ target_compile_options(wasserstein_dist_point_cloud PRIVATE /W4 /WX)
+else()
+ target_compile_options(wasserstein_dist PRIVATE -Wall -Wextra -Wpedantic)
+ target_compile_options(wasserstein_dist_dipha PRIVATE -Wall -Wextra -Wpedantic)
+ target_compile_options(wasserstein_dist_point_cloud PRIVATE -Wall -Wextra -Wpedantic)
+endif()
+
+