summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Merry <dev@randomguy3.me.uk>2013-08-03 10:37:06 +0100
committerAlex Merry <dev@randomguy3.me.uk>2013-08-03 10:37:06 +0100
commit0b419a4d47e7e67837eba4c6b9d52ef664938f9d (patch)
treea458765e6a94bdb01f6cad85e8c073b819154d8d
parentcb952e6cbace0230b46b9267c964e415cf378b23 (diff)
Demand actual bison and flex, rather than yacc and lex
We use bison/flex extensions, so we need those actual tools.
-rw-r--r--tikzit/configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/tikzit/configure.ac b/tikzit/configure.ac
index 8f791b6..99697c5 100644
--- a/tikzit/configure.ac
+++ b/tikzit/configure.ac
@@ -21,8 +21,19 @@ AC_PROG_OBJC([gcc clang objc objcc])
AC_LANG([Objective C])
AC_PROG_LEX
-AM_PROG_LEX
+AS_IF([$LEX --version 2>/dev/null | grep "^flex" >/dev/null 2>/dev/null],[],
+ [
+ AC_MSG_WARN([flex not found; this may cause problems for developers])
+ LEX="\${SHELL} \$(top_srcdir)/missing flex"
+ AC_SUBST([LEX_OUTPUT_ROOT], [lex.yy])
+ AC_SUBST([LEXLIB], [''])
+ ])
AC_PROG_YACC
+AS_IF([$YACC --version 2>/dev/null | grep "^bison" >/dev/null 2>/dev/null],[],
+ [
+ AC_MSG_WARN([bison not found; this may cause problems for developers])
+ YACC="\${SHELL} \$(top_srcdir)/missing bison"
+ ])
# Checks for libraries.
FOUNDATION_OBJCFLAGS=`eval "gnustep-config --objc-flags"`