summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Merry <dev@randomguy3.me.uk>2013-08-07 00:43:49 +0100
committerAlex Merry <dev@randomguy3.me.uk>2013-08-07 00:45:50 +0100
commit5a94458d9ee3ee8afd978477c755200df432a9b0 (patch)
treebea24359a6300f4dd2ce4d1ad517f63a52cca972
parente306c53d9e31c7ee09a131c765cbcec67fdd2565 (diff)
Add variant of stringWithContentsOfFile that produces an error
It turns out that the [NSString stringWithContentsOfFile:] family of methods do not have a way of reporting why a file could not be read; [NSString stringWithContentsOfFile:usedEncoding:error:] will only set the error object if there was a problem with decoding. So, we cook our own variant that tries to figure out why opening the file failed. User-visible effect: in the GTK+ port, if you try to open a file from the "open recent" menu that no longer exists, you will get a more helpful error message.
-rw-r--r--tikzit/src/Makefile.am1
-rw-r--r--tikzit/src/common/NSString+Util.h27
-rw-r--r--tikzit/src/common/NSString+Util.m66
-rw-r--r--tikzit/src/gtk/TZFoundation.h1
-rw-r--r--tikzit/src/gtk/TikzDocument.m4
5 files changed, 96 insertions, 3 deletions
diff --git a/tikzit/src/Makefile.am b/tikzit/src/Makefile.am
index e869686..c679afa 100644
--- a/tikzit/src/Makefile.am
+++ b/tikzit/src/Makefile.am
@@ -90,6 +90,7 @@ tikzit_SOURCES = gtk/Application.m \
common/NSFileManager+Utils.m \
common/NSString+LatexConstants.m \
common/NSString+Tikz.m \
+ common/NSString+Util.m \
common/PickSupport.m \
common/PropertyHolder.m \
common/GraphElementProperty.m \
diff --git a/tikzit/src/common/NSString+Util.h b/tikzit/src/common/NSString+Util.h
new file mode 100644
index 0000000..548edb3
--- /dev/null
+++ b/tikzit/src/common/NSString+Util.h
@@ -0,0 +1,27 @@
+/*
+ * Copyright 2013 Alex Merry <alex.merry@kdemail.net>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of
+ * the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#import <Foundation/Foundation.h>
+
+@interface NSString (Util)
+ + (NSString*) stringWithContentsOfFile:(NSString*)path
+ error:(NSError**)error;
+ - (id) initWithContentsOfFile:(NSString*)path
+ error:(NSError**)error;
+@end
+
+// vi:ft=objc:noet:ts=4:sts=4:sw=4
diff --git a/tikzit/src/common/NSString+Util.m b/tikzit/src/common/NSString+Util.m
new file mode 100644
index 0000000..b18f397
--- /dev/null
+++ b/tikzit/src/common/NSString+Util.m
@@ -0,0 +1,66 @@
+/*
+ * Copyright 2013 Alex Merry <alex.merry@kdemail.net>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of
+ * the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#import <Foundation/Foundation.h>
+#import "NSString+Util.h"
+#import "NSError+Tikzit.h"
+
+@implementation NSString (Util)
++ (NSString*) stringWithContentsOfFile:(NSString*)path
+ error:(NSError**)error
+{
+ return [[[self alloc] initWithContentsOfFile:path error:error] autorelease];
+}
+- (id) initWithContentsOfFile:(NSString*)path
+ error:(NSError**)error
+{
+ // Fun fact: on GNUstep, at least,
+ // [stringWithContentsOfFile:usedEncoding:error:] only
+ // sets error objects if the decoding fails, not if file
+ // access fails.
+ // Fun fact 2: on GNUstep, trying to read a directory using
+ // [stringWithContentsOfFile:] causes an out-of-memory error;
+ // hence we do these checks *before* trying to read the file.
+ NSFileManager *fm = [NSFileManager defaultManager];
+ BOOL isDir = NO;
+ NSString *msg = nil;
+ if (![fm fileExistsAtPath:path isDirectory:&isDir]) {
+ msg = [NSString stringWithFormat:@"\"%@\" does not exist", path];
+ } else if (isDir) {
+ msg = [NSString stringWithFormat:@"\"%@\" is a directory", path];
+ } else if (![fm isReadableFileAtPath:path]) {
+ msg = [NSString stringWithFormat:@"\"%@\" is not readable", path];
+ }
+ if (msg != nil) {
+ if (error) {
+ *error = [NSError errorWithMessage:msg
+ code:TZ_ERR_IO];
+ }
+ return nil;
+ }
+ self = [self initWithContentsOfFile:path];
+ if (self == nil) {
+ if (error) {
+ *error = [NSError errorWithMessage:@"unknown error"
+ code:TZ_ERR_IO];
+ }
+ }
+ return self;
+}
+@end
+
+// vi:ft=objc:noet:ts=4:sts=4:sw=4
diff --git a/tikzit/src/gtk/TZFoundation.h b/tikzit/src/gtk/TZFoundation.h
index f275004..2ff20ca 100644
--- a/tikzit/src/gtk/TZFoundation.h
+++ b/tikzit/src/gtk/TZFoundation.h
@@ -25,5 +25,6 @@
#import "NSString+Glib.h"
#import "NSString+LatexConstants.h"
#import "NSString+Tikz.h"
+#import "NSString+Util.h"
// vim:ft=objc:ts=8:et:sts=4:sw=4
diff --git a/tikzit/src/gtk/TikzDocument.m b/tikzit/src/gtk/TikzDocument.m
index 6e013b1..bff5a2e 100644
--- a/tikzit/src/gtk/TikzDocument.m
+++ b/tikzit/src/gtk/TikzDocument.m
@@ -139,9 +139,7 @@
styleManager:(StyleManager*)manager
error:(NSError**)error
{
- NSStringEncoding enc; // we can't pass in NULL here...
- NSString *t = [NSString stringWithContentsOfFile:pth
- usedEncoding:&enc error:error];
+ NSString *t = [NSString stringWithContentsOfFile:pth error:error];
if (t == nil) {
[self release];
return nil;