summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Merry <alex.merry@cs.ox.ac.uk>2013-02-04 17:29:37 +0000
committerAlex Merry <alex.merry@cs.ox.ac.uk>2013-02-04 17:31:07 +0000
commit0f2452356ae718b73e9467e388092c8af6752a8f (patch)
tree14e10500279c46e43eab6143ae9b4a3f4568776c
parent82eb38daca527719d56798d4a533b1add6882717 (diff)
{-quote keys as well as values in property lists
-rw-r--r--tikzit/src/Makefile.am1
-rw-r--r--tikzit/src/common/GraphElementProperty.m18
-rw-r--r--tikzit/src/common/NSString+Tikz.h25
-rw-r--r--tikzit/src/common/NSString+Tikz.m59
4 files changed, 91 insertions, 12 deletions
diff --git a/tikzit/src/Makefile.am b/tikzit/src/Makefile.am
index 2f3c5b2..6ffaa26 100644
--- a/tikzit/src/Makefile.am
+++ b/tikzit/src/Makefile.am
@@ -89,6 +89,7 @@ tikzit_SOURCES = gtk/Application.m \
common/NSError+Tikzit.m \
common/NSFileManager+Utils.m \
common/NSString+LatexConstants.m \
+ common/NSString+Tikz.m \
common/PickSupport.m \
common/PropertyHolder.m \
common/GraphElementProperty.m \
diff --git a/tikzit/src/common/GraphElementProperty.m b/tikzit/src/common/GraphElementProperty.m
index 4fcb964..2eb6a5f 100644
--- a/tikzit/src/common/GraphElementProperty.m
+++ b/tikzit/src/common/GraphElementProperty.m
@@ -23,7 +23,7 @@
//
#import "GraphElementProperty.h"
-
+#import "NSString+Tikz.h"
@implementation GraphElementProperty
@@ -114,19 +114,13 @@
- (NSString*)description {
if ([self isAtom]) {
- return [self key];
+ return [[self key] tikzEscapedString];
} else if ([self isKeyMatch]) {
- return [NSString stringWithFormat:@"%@=*", [self key]];
+ return [NSString stringWithFormat:@"%@=*", [[self key] tikzEscapedString]];
} else {
- static NSCharacterSet *avoid = nil;
- if (avoid == nil)
- avoid = [[[NSCharacterSet characterSetWithCharactersInString:@"abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ<>-'0123456789. "] invertedSet] retain];
-
- if ([[self value] rangeOfCharacterFromSet:avoid].length > 0) {
- return [NSString stringWithFormat:@"%@={%@}", [self key], [self value]];
- } else {
- return [NSString stringWithFormat:@"%@=%@", [self key], [self value]];
- }
+ return [NSString stringWithFormat:@"%@=%@",
+ [[self key] tikzEscapedString],
+ [[self value] tikzEscapedString]];
}
}
diff --git a/tikzit/src/common/NSString+Tikz.h b/tikzit/src/common/NSString+Tikz.h
new file mode 100644
index 0000000..639e269
--- /dev/null
+++ b/tikzit/src/common/NSString+Tikz.h
@@ -0,0 +1,25 @@
+/*
+ * Copyright 2013 Alex Merry <alex.merry@kdemail.net>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of
+ * the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#import <Foundation/Foundation.h>
+
+@interface NSString (Tikz)
+ - (NSString*) tikzEscapedString;
+ - (BOOL) isValidTikz;
+@end
+
+// vi:ft=objc:noet:ts=4:sts=4:sw=4
diff --git a/tikzit/src/common/NSString+Tikz.m b/tikzit/src/common/NSString+Tikz.m
new file mode 100644
index 0000000..85a51d3
--- /dev/null
+++ b/tikzit/src/common/NSString+Tikz.m
@@ -0,0 +1,59 @@
+/*
+ * Copyright 2013 Alex Merry <alex.merry@kdemail.net>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of
+ * the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#import "NSString+Tikz.h"
+#import "TikzGraphAssembler.h"
+
+@implementation NSString (Tikz)
+
+- (NSString*) tikzEscapedString {
+ static NSCharacterSet *avoid = nil;
+ if (avoid == nil)
+ avoid = [[[NSCharacterSet characterSetWithCharactersInString:@"abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ<>-'0123456789. "] invertedSet] retain];
+
+ if ([self rangeOfCharacterFromSet:avoid].length > 0) {
+ return [NSString stringWithFormat:@"{%@}", self];
+ } else {
+ return [[self retain] autorelease];
+ }
+}
+
+- (BOOL) isValidTikz {
+ NSUInteger length = [self length];
+ unsigned int brace_depth = 0;
+ unsigned int escape = 0;
+ for (NSUInteger i = 0; i < length; ++i) {
+ unichar c = [self characterAtIndex:i];
+
+ if (escape) {
+ escape = 0;
+ } else if (c == '\\') {
+ escape = 1;
+ } else if (c == '{') {
+ brace_depth++;
+ } else if (c == '}') {
+ if (brace_depth == 0)
+ return NO;
+ brace_depth--;
+ }
+ }
+ return !escape && brace_depth == 0;
+}
+
+@end
+
+// vi:ft=objc:noet:ts=4:sts=4:sw=4