summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Merry <dev@randomguy3.me.uk>2013-08-03 19:49:31 +0100
committerAlex Merry <dev@randomguy3.me.uk>2013-08-03 19:49:31 +0100
commit7f818c136f5a37ac7ba332c2ba0e471ae0cb9bd7 (patch)
tree21ee0d19a9b2bd14d3b797e0f2483f1344362846
parent75b2d46afcfb5534465556bfa9d46999c7a69d84 (diff)
Better dependency information
Be explicit about what versions we require.
-rw-r--r--tikzit/INSTALL14
-rw-r--r--tikzit/configure.ac4
-rw-r--r--tikzit/src/common/tikzparser.ym3
3 files changed, 14 insertions, 7 deletions
diff --git a/tikzit/INSTALL b/tikzit/INSTALL
index 695982d..9576d37 100644
--- a/tikzit/INSTALL
+++ b/tikzit/INSTALL
@@ -3,11 +3,15 @@ For building on systems other than MacOS/X:
Dependencies:
GNUstep (core libraries) >= 1.18.0
gtk+-2.0 >= 2.18.0
- poppler (including glib bindings, which may be in
- a separate poppler-glib package)
+ gdk-pixbuf >= 2.16.0
+ poppler >= 0.10
+ including glib bindings, which may be in
+ a separate poppler-glib package
Objective C compiler (eg: gcc with ObjC support) with
support for properties, optional protocols and
fast enumeration (eg: gcc 4.6 or clang).
+ pkg-config
+ build-time dependency only
To install, just run:
@@ -18,10 +22,10 @@ To install, just run:
To build from subversion (and for development) you will additionally need:
- lex (eg: flex)
- yacc (eg: bison)
+ flex >= 2.5.34
+ bison >= 2.4
autoconf >= 2.60
- automake
+ automake >= 1.10
and you will need to prepare the source tree by running
./autogen.sh
diff --git a/tikzit/configure.ac b/tikzit/configure.ac
index 42f09ee..296daa5 100644
--- a/tikzit/configure.ac
+++ b/tikzit/configure.ac
@@ -6,8 +6,8 @@ AC_INIT([TikZiT], [1.0],
[http://sourceforge.net/apps/trac/tikzit],
[tikzit],
[http://tikzit.sourceforge.net])
-AM_INIT_AUTOMAKE([foreign subdir-objects -Wall -Werror])
-AM_SILENT_RULES([yes])
+AM_INIT_AUTOMAKE([1.10 foreign subdir-objects -Wall -Werror])
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_OUTPUT(Makefile
src/Makefile
share/Makefile
diff --git a/tikzit/src/common/tikzparser.ym b/tikzit/src/common/tikzparser.ym
index 9901f79..bf33aa9 100644
--- a/tikzit/src/common/tikzparser.ym
+++ b/tikzit/src/common/tikzparser.ym
@@ -20,6 +20,9 @@
*/
%}
+/* we use features added to bison 2.4 */
+%require "2.4"
+
%error-verbose
/* enable maintaining locations for better error messages */
%locations