summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-22 12:47:49 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-22 12:47:49 +0000
commitf8e33c3e6e73efe8290de3c4712b720cedfb4138 (patch)
treef64a45b40208ce1e8e5d9e54bae246d94d0c033f /CMakeLists.txt
parenta135db991a6c7a49659b77660796c99c7cddb1dc (diff)
-pedantic is only for developpers
Bug fix in gudhi_patches mechanism git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/cmake_v3_vincent@3448 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 0ecb0da6e6c63733a800a2f30b0f50d2c7e29441
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 08291b54..d3474681 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,8 @@ set(GUDHI_CYTHON_PATH "src/cython")
include(GUDHI_third_party_libraries NO_POLICY_SCOPE)
include(GUDHI_compilation_flags)
+# Only for dev version
+add_cxx_compiler_flag("-pedantic")
# Add your new module in the list, order is not important
include(GUDHI_modules)