summaryrefslogtreecommitdiff
path: root/src/Bottleneck_distance/test/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-13 07:30:29 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-13 07:30:29 +0000
commitb57185091b250252fe343a572cef6195bca47d2e (patch)
treeeedc4090fd9c8e35bd1fdbd6d10b4bdfcca35df8 /src/Bottleneck_distance/test/CMakeLists.txt
parent35c679061122f630358d927bd22089c1d4c0c8cd (diff)
parentaa9705ab541323e1d7aa0129c8faf0416b0489e0 (diff)
Merge branch bottleneckDistance on a up-to-date branch
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/bottleneck_integration@1492 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: bccdeaf8456b7b88ad2da71205dbb4c5d08a53ee
Diffstat (limited to 'src/Bottleneck_distance/test/CMakeLists.txt')
-rw-r--r--src/Bottleneck_distance/test/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/Bottleneck_distance/test/CMakeLists.txt b/src/Bottleneck_distance/test/CMakeLists.txt
new file mode 100644
index 00000000..ba0f5fee
--- /dev/null
+++ b/src/Bottleneck_distance/test/CMakeLists.txt
@@ -0,0 +1,29 @@
+cmake_minimum_required(VERSION 2.6)
+project(Bottleneck_distance_tests)
+
+
+if (GCOVR_PATH)
+ # for gcovr to make coverage reports - Corbera Jenkins plugin
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
+endif()
+if (GPROF_PATH)
+ # for gprof to make coverage reports - Jenkins
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pg")
+endif()
+
+# need CGAL 4.7
+# cmake -DCGAL_DIR=~/workspace/CGAL-4.7-Ic-41 ../../..
+if(CGAL_FOUND)
+ if (NOT CGAL_VERSION VERSION_LESS 4.7.0)
+ if (EIGEN3_FOUND)
+ add_executable ( bottleneckUT bottleneck_unit_test.cpp )
+ add_executable ( bottleneck_chrono bottleneck_chrono.cpp )
+ target_link_libraries(bottleneckUT ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+
+ # Unitary tests
+ add_test(NAME bottleneckUT COMMAND ${CMAKE_CURRENT_BINARY_DIR}/bottleneckUT
+ # XML format for Jenkins xUnit plugin
+ --log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/bottleneckUT.xml --log_level=test_suite --report_level=no)
+ endif()
+ endif ()
+endif()