summaryrefslogtreecommitdiff
path: root/src/GudhUI/CMakeLists.txt
diff options
context:
space:
mode:
authormcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-07 09:10:45 +0000
committermcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-07 09:10:45 +0000
commit3182c852e0cfbb772dfe27e30647034d9fa35a32 (patch)
tree38238e83ae2b13bc1d2c9c728a6da4a2dffee7c0 /src/GudhUI/CMakeLists.txt
parent9cb300d538a4466df50927cf31de3c06e914cb90 (diff)
parent20dce046a003850f49c4e1d995348bc8e4cef85b (diff)
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/Nerve_GIC@2838 636b058d-ea47-450e-bf9e-a15bfbe3eedb
Former-commit-id: aa674c458f110c5c7cc3f5c987b921fcc96e3e7e
Diffstat (limited to 'src/GudhUI/CMakeLists.txt')
-rw-r--r--src/GudhUI/CMakeLists.txt34
1 files changed, 4 insertions, 30 deletions
diff --git a/src/GudhUI/CMakeLists.txt b/src/GudhUI/CMakeLists.txt
index ca2e47c1..374195d0 100644
--- a/src/GudhUI/CMakeLists.txt
+++ b/src/GudhUI/CMakeLists.txt
@@ -5,28 +5,6 @@ find_package(Qt5 COMPONENTS Widgets Xml OpenGL)
find_package(QGLViewer)
find_package(OpenGL)
-if (CGAL_VERSION VERSION_EQUAL 4.8.0)
- message(ERROR " GudhUI does not compile with CGAL 4.8.0. 4.8.1, 4.8.2 and 4.9 are OK.")
-endif()
-
-if (NOT CGAL_FOUND)
- message(ERROR " GudhUI requires CGAL and will not be compiled.")
-endif()
-
-if (NOT Qt5_FOUND)
- message(ERROR " GudhUI requires Qt5 and will not be compiled.")
-endif()
-
-if (NOT OPENGL_FOUND)
- message(ERROR " GudhUI requires OpenGL and will not be compiled.")
-endif()
-
-if (NOT QGLVIEWER_FOUND)
- message(ERROR " GudhUI requires QGLViewer and will not be compiled.")
-endif()
-
-
-
if ( CGAL_FOUND AND Qt5_FOUND AND OPENGL_FOUND AND QGLVIEWER_FOUND AND NOT CGAL_VERSION VERSION_EQUAL 4.8.0)
set(CMAKE_AUTOMOC ON)
@@ -37,8 +15,6 @@ if ( CGAL_FOUND AND Qt5_FOUND AND OPENGL_FOUND AND QGLVIEWER_FOUND AND NOT CGAL_
SET(Boost_USE_MULTITHREAD OFF)
include_directories (${QGLVIEWER_INCLUDE_DIR})
- #####################################################################
-
add_executable ( GudhUI
gui/gudhui.cpp
gui/MainWindow.cpp
@@ -52,12 +28,10 @@ if ( CGAL_FOUND AND Qt5_FOUND AND OPENGL_FOUND AND QGLVIEWER_FOUND AND NOT CGAL_
target_link_libraries( GudhUI Qt5::Widgets Qt5::Xml Qt5::OpenGL )
target_link_libraries( GudhUI ${QGLVIEWER_LIBRARIES} )
target_link_libraries( GudhUI ${OPENGL_gl_LIBRARY} ${OPENGL_glu_LIBRARY} )
-if (TBB_FOUND)
- target_link_libraries( GudhUI ${TBB_LIBRARIES})
-endif()
+ if (TBB_FOUND)
+ target_link_libraries( GudhUI ${TBB_LIBRARIES})
+ endif()
-###############################################################################
+ install(TARGETS GudhUI DESTINATION bin)
-else()
- message(STATUS "NOTICE: GudhUI requires CGAL, the QGLViewer, OpenGL and Qt5, and will not be compiled.")
endif()