summaryrefslogtreecommitdiff
path: root/src/Persistence_representations/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-01-08 13:34:18 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-01-08 13:34:18 +0000
commit8ce961c5d86845613a196e2a5b1e3ea724698d88 (patch)
tree2bf3b92950a6e1fedc9aa44a24e096cf96bcf821 /src/Persistence_representations/example/CMakeLists.txt
parent7cf0599b211bc6cd5e8a64a75550cdf40b3fbb14 (diff)
parent22ab936a67cdf649091599526f239bdb263100f9 (diff)
Merge of branch persistence_representation_integration_cmake_improvement
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@3117 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 673143bd16e06d990aeb104a506cfd71f91a8717
Diffstat (limited to 'src/Persistence_representations/example/CMakeLists.txt')
-rw-r--r--src/Persistence_representations/example/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/Persistence_representations/example/CMakeLists.txt b/src/Persistence_representations/example/CMakeLists.txt
index 7788b603..b8ce8ea6 100644
--- a/src/Persistence_representations/example/CMakeLists.txt
+++ b/src/Persistence_representations/example/CMakeLists.txt
@@ -1,8 +1,6 @@
cmake_minimum_required(VERSION 2.6)
project(Persistence_representations_example)
-file(COPY "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/")
-
add_executable ( Persistence_representations_example_landscape_on_grid persistence_landscape_on_grid.cpp )
target_link_libraries(Persistence_representations_example_landscape_on_grid ${Boost_SYSTEM_LIBRARY})
add_test(NAME Persistence_representations_example_landscape_on_grid
@@ -17,7 +15,7 @@ add_executable ( Persistence_representations_example_intervals persistence_inter
target_link_libraries(Persistence_representations_example_intervals ${Boost_SYSTEM_LIBRARY})
add_test(NAME Persistence_representations_example_intervals
COMMAND $<TARGET_FILE:Persistence_representations_example_intervals>
- "${CMAKE_CURRENT_BINARY_DIR}/simple_diagram.txt")
+ "${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers")
add_executable ( Persistence_representations_example_vectors persistence_vectors.cpp )
target_link_libraries(Persistence_representations_example_vectors ${Boost_SYSTEM_LIBRARY})