summaryrefslogtreecommitdiff
path: root/src/common/utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-05-31 09:25:27 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-05-31 09:25:27 +0000
commitbbe2c8670f84862dcc2b791f66cd1a668e295a81 (patch)
tree683d40ca5117da61ea1e0fab617378deb84d2368 /src/common/utilities/CMakeLists.txt
parent6d4b5ec65b863abb5b183635a0e64341c19e7b4b (diff)
parent7035590cdfd71eb7454d638f3b479d62a0ebadf4 (diff)
Merge from trunk
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/read_persistence_from_file@2482 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 5487cc3f399d42f736ec008f40c4082d51e3f683
Diffstat (limited to 'src/common/utilities/CMakeLists.txt')
-rw-r--r--src/common/utilities/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/common/utilities/CMakeLists.txt b/src/common/utilities/CMakeLists.txt
new file mode 100644
index 00000000..c2e07e7e
--- /dev/null
+++ b/src/common/utilities/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 2.6)
+project(off_file_from_shape_generator)
+
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)
+ add_executable ( off_file_from_shape_generator off_file_from_shape_generator.cpp )
+ target_link_libraries(off_file_from_shape_generator ${Boost_SYSTEM_LIBRARY})
+ add_test(NAME off_file_from_shape_generator_on_sphere_1000_3_15.2 COMMAND $<TARGET_FILE:off_file_from_shape_generator>
+ "on" "sphere" "onSphere.off" "1000" "3" "15.2")
+ add_test(NAME off_file_from_shape_generator_in_sphere_100_2 COMMAND $<TARGET_FILE:off_file_from_shape_generator>
+ "in" "sphere" "inSphere.off" "100" "2")
+
+ # on cube is not available in CGAL
+ add_test(NAME off_file_from_shape_generator_in_cube_10000_3_5.8 COMMAND $<TARGET_FILE:off_file_from_shape_generator>
+ "in" "cube" "inCube.off" "10000" "3" "5.8")
+
+ install(TARGETS off_file_from_shape_generator DESTINATION bin)
+
+endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)