summaryrefslogtreecommitdiff
path: root/src/Alpha_shapes/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Alpha_shapes/test/CMakeLists.txt')
-rw-r--r--src/Alpha_shapes/test/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Alpha_shapes/test/CMakeLists.txt b/src/Alpha_shapes/test/CMakeLists.txt
index 7d61a3dd..e2dd786c 100644
--- a/src/Alpha_shapes/test/CMakeLists.txt
+++ b/src/Alpha_shapes/test/CMakeLists.txt
@@ -8,6 +8,15 @@ if(CGAL_FOUND)
message(STATUS "CGAL version: ${CGAL_VERSION}.")
include( ${CGAL_USE_FILE} )
+
+ if(NOT MSVC)
+ include(CheckCXXCompilerFlag)
+ CHECK_CXX_COMPILER_FLAG(-std=c++11 COMPILER_SUPPORTS_CXX11)
+ if(COMPILER_SUPPORTS_CXX11)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+ endif()
+ endif()
+ # - End of workaround
find_package(Eigen3 3.1.0)
if (EIGEN3_FOUND)