summaryrefslogtreecommitdiff
path: root/src/Witness_complex/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Witness_complex/example/CMakeLists.txt')
-rw-r--r--src/Witness_complex/example/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Witness_complex/example/CMakeLists.txt b/src/Witness_complex/example/CMakeLists.txt
index c18d59d2..2691479d 100644
--- a/src/Witness_complex/example/CMakeLists.txt
+++ b/src/Witness_complex/example/CMakeLists.txt
@@ -1,7 +1,13 @@
cmake_minimum_required(VERSION 2.6)
project(Witness_complex_examples)
+add_executable ( Witness_complex_example_nearest_landmark_table example_nearest_landmark_table.cpp )
+if (TBB_FOUND)
+ target_link_libraries(Witness_complex_example_nearest_landmark_table ${TBB_LIBRARIES})
+endif()
+add_test(Witness_complex_test_nearest_landmark_table Witness_complex_example_nearest_landmark_table)
+# CGAL and Eigen3 are required for Euclidean version of Witness
if(CGAL_FOUND)
if (NOT CGAL_VERSION VERSION_LESS 4.6.0)
if (EIGEN3_FOUND)
@@ -15,11 +21,9 @@ if(CGAL_FOUND)
add_executable ( Witness_complex_example_strong_witness_persistence example_strong_witness_persistence.cpp )
target_link_libraries(Witness_complex_example_strong_witness_persistence ${Boost_PROGRAM_OPTIONS_LIBRARY})
- add_executable ( Witness_complex_example_nearest_landmark_table example_nearest_landmark_table.cpp )
if (TBB_FOUND)
target_link_libraries(Witness_complex_example_witness_persistence ${TBB_LIBRARIES})
target_link_libraries(Witness_complex_example_strong_witness_persistence ${TBB_LIBRARIES})
- target_link_libraries(Witness_complex_example_nearest_landmark_table ${TBB_LIBRARIES})
endif()
add_test(Witness_complex_off_test_torus
@@ -35,7 +39,6 @@ if(CGAL_FOUND)
add_test(Witness_complex_strong_test_torus_persistence
${CMAKE_CURRENT_BINARY_DIR}/Witness_complex_example_strong_witness_persistence
${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off -l 20 -a 0.5)
- add_test(Witness_complex_test_nearest_landmark_table Witness_complex_example_nearest_landmark_table)
endif(EIGEN3_FOUND)
endif (NOT CGAL_VERSION VERSION_LESS 4.6.0)
endif()