summaryrefslogtreecommitdiff
path: root/src/cython/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/cython/CMakeLists.txt')
-rw-r--r--src/cython/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/cython/CMakeLists.txt b/src/cython/CMakeLists.txt
index 2746cab9..c2026682 100644
--- a/src/cython/CMakeLists.txt
+++ b/src/cython/CMakeLists.txt
@@ -49,8 +49,16 @@ if(PYTHON_PATH AND CYTHON_PATH)
file(COPY test DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
if (CGAL_FOUND)
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+ # If CGAL_VERSION >= 4.8.1, include subsampling
+ # CGAL things are done in CGAL_VERSION >= 4.8.0
+ set(GUDHI_CYTHON_SUBSAMPLING "include 'cython/subsampling.pyx'")
+ else (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+ # Remove alpha complex unitary tests
+ file(REMOVE ${CMAKE_CURRENT_BINARY_DIR}/test/test_subsampling.py)
+ endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)
if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
- # If CGAL_VERSION >= 4.8.0, include alpha complex
+ # If CGAL_VERSION >= 4.8.0, include alpha and tangential complex
set(GUDHI_CYTHON_LIBRARIES "${GUDHI_CYTHON_LIBRARIES}'CGAL', ")
set(GUDHI_CYTHON_LIBRARY_DIRS "${GUDHI_CYTHON_LIBRARY_DIRS}'${CGAL_LIBRARIES_DIR}', ")
# GMP and GMPXX are not required, but if present, CGAL will link with them.