summaryrefslogtreecommitdiff
path: root/src/cython/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'src/cython/setup.py')
-rw-r--r--src/cython/setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/cython/setup.py b/src/cython/setup.py
index 92ed6bbd..5b99ba5f 100644
--- a/src/cython/setup.py
+++ b/src/cython/setup.py
@@ -1,6 +1,32 @@
from distutils.core import setup, Extension
from Cython.Build import cythonize
+"""This file is part of the Gudhi Library. The Gudhi library
+ (Geometric Understanding in Higher Dimensions) is a generic C++
+ library for computational topology.
+
+ Author(s): Vincent Rouvreau
+
+ Copyright (C) 2016 INRIA Saclay (France)
+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+"""
+
+__author__ = "Vincent Rouvreau"
+__copyright__ = "Copyright (C) 2016 INRIA Saclay (France)"
+__license__ = "GPL v3"
+
gudhi = Extension(
"gudhi",
sources = ['gudhi.pyx',],