summaryrefslogtreecommitdiff
path: root/src/cython/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'src/cython/setup.py')
-rw-r--r--src/cython/setup.py15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/cython/setup.py b/src/cython/setup.py
new file mode 100644
index 00000000..26a46590
--- /dev/null
+++ b/src/cython/setup.py
@@ -0,0 +1,15 @@
+from distutils.core import setup, Extension
+from Cython.Build import cythonize
+
+gudhi = Extension(
+ "gudhi",
+ sources = ['gudhi.pyx',],
+ language = 'c++',
+ extra_compile_args=['-std=c++11'],
+ include_dirs = ['..'],
+)
+
+setup(
+ name = 'gudhi',
+ ext_modules = cythonize(gudhi),
+)