summaryrefslogtreecommitdiff
path: root/geom_matching/wasserstein/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'geom_matching/wasserstein/CMakeLists.txt')
-rw-r--r--geom_matching/wasserstein/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/geom_matching/wasserstein/CMakeLists.txt b/geom_matching/wasserstein/CMakeLists.txt
index 98f3cfd..b59378c 100644
--- a/geom_matching/wasserstein/CMakeLists.txt
+++ b/geom_matching/wasserstein/CMakeLists.txt
@@ -5,6 +5,12 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
include (GenerateExportHeader)
+include(TestBigEndian)
+test_big_endian(BIG_ENDIAN)
+if(BIG_ENDIAN)
+ add_definitions(-DBIGENDIAN)
+endif()
+
# Default to Release
if (NOT CMAKE_BUILD_TYPE)
@@ -43,6 +49,9 @@ set (libraries ${libraries} ${CMAKE_THREAD_LIBS_INIT})
add_executable(wasserstein_dist ${CMAKE_CURRENT_SOURCE_DIR}/example/wasserstein_dist.cpp ${WS_HEADERS})
target_link_libraries(wasserstein_dist PUBLIC ${libraries})
+add_executable(wasserstein_dist_dipha ${CMAKE_CURRENT_SOURCE_DIR}/example/wasserstein_dist_dipha.cpp ${WS_HEADERS})
+target_link_libraries(wasserstein_dist_dipha PUBLIC ${libraries})
+
# pure geometric version, arbitrary dimension
add_executable(wasserstein_dist_point_cloud ${CMAKE_CURRENT_SOURCE_DIR}/example/wasserstein_dist_point_cloud.cpp ${WS_HEADERS})
target_link_libraries(wasserstein_dist_point_cloud PUBLIC ${libraries})