summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gard.spreemann@epfl.ch>2017-09-21 13:35:50 +0200
committerGard Spreemann <gard.spreemann@epfl.ch>2017-09-21 13:35:50 +0200
commitaa1134796c1d4003dbdf9dc92a1b7d00598f67ce (patch)
tree3b53aa6a1de5bdfd37ef954ae9261990cee55763 /CMakeLists.txt
Initial commit.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..4b4c13e
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 2.8.8)
+
+project(lapdog)
+
+find_package(MPI REQUIRED)
+include_directories(${MPI_INCLUDE_PATH})
+link_directories(${MPI_LIBRARIES})
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${MPI_COMPILE_FLAGS} -Wall -pedantic -Wextra -std=c++14")
+set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} ${MPI_LINK_FLAGS}")
+
+add_subdirectory(src)