summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c3eca00
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,10 @@
+from setuptools import setup
+
+setup(name="scnn",
+ version="0.1",
+ description="Convolutional layer for cochains on simplicial complexes",
+ author="Gard Spreemann",
+ author_email="gard.spreemann@epfl.ch",
+ license="GPL-3",
+ packages=["scnn"],
+ install_requires=["torch", "numpy", "scipy"])