summaryrefslogtreecommitdiff
path: root/.circleci
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-10-25 15:34:03 +0200
committerHind-M <hind.montassif@gmail.com>2021-10-25 15:34:03 +0200
commit5db7ab2b55262a88c0ceecbb9c7ea004d9ed087e (patch)
tree7090f11f28261d5b733eb70f7b9657298144b8dd /.circleci
parentc9d6439fb9a6e65d7aa9f18bce675de65e901a0d (diff)
Enable WITH_GUDHI_REMOTE_TEST option for python target in CI platforms
Diffstat (limited to '.circleci')
-rw-r--r--.circleci/config.yml20
1 files changed, 1 insertions, 19 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index 262e124b..90737006 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -61,7 +61,7 @@ jobs:
cmake -DUSER_VERSION_DIR=version ..
make user_version
cd version
- cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 .
+ cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 -DWITH_GUDHI_REMOTE_TEST=ON .
cd python
python3 setup.py build_ext --inplace
make sphinx
@@ -77,23 +77,6 @@ jobs:
path: /tmp/htmlcov
destination: htmlcov
- python_tests_with_network:
- docker:
- - image: gudhi/ci_for_gudhi:latest
- steps:
- - checkout
- - run:
- name: Build and test python module with network
- command: |
- git submodule init
- git submodule update
- mkdir build
- cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_REMOTE_TEST=ON ..
- cd src/python
- python3 setup.py build_ext --inplace
- ctest --output-on-failure
-
doxygen:
docker:
- image: gudhi/ci_for_gudhi:latest
@@ -262,5 +245,4 @@ workflows:
- tests
- utils
- python
- - python_tests_with_network
- doxygen