summaryrefslogtreecommitdiff
path: root/.circleci
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-09-27 17:32:55 +0200
committerHind-M <hind.montassif@gmail.com>2021-09-27 17:32:55 +0200
commit613db2444a9a12a64b097b944d0180e4fdbff71f (patch)
treec38ee8d325a367ee8f05bc1d3ca7cf1a8b434a0b /.circleci
parent8749199e00c0ed1c32b8e0198a65797de3ad192a (diff)
Document option WITH_NETWORK in installation manual and tests_strategy
Enable WITH_NETWORK option in some of the CI platforms (for a minimal testing)
Diffstat (limited to '.circleci')
-rw-r--r--.circleci/config.yml18
1 files changed, 18 insertions, 0 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index f6a875dd..85e42f8a 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -77,6 +77,23 @@ jobs:
path: /tmp/htmlcov
destination: htmlcov
+ python_tests_with_network:
+ docker:
+ - image: gudhi/ci_for_gudhi:latest
+ steps:
+ - checkout
+ - run:
+ name: Build and test python module with network
+ command: |
+ git submodule init
+ git submodule update
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 -DWITH_GUDHI_TEST=ON -DWITH_NETWORK=ON ..
+ cd src/python
+ python3 setup.py build_ext --inplace
+ ctest --output-on-failure
+
doxygen:
docker:
- image: gudhi/ci_for_gudhi:latest
@@ -245,4 +262,5 @@ workflows:
- tests
- utils
- python
+ - python_tests_with_network
- doxygen