summaryrefslogtreecommitdiff
path: root/.circleci
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-01-22 11:29:11 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-01-22 11:29:11 +0100
commit7923b83d1ccf03f1c8b0a7fcd73e199894784a45 (patch)
tree1f758b12c9256b44d2818322fd1f641c62b4e1ef /.circleci
parentf051d6111f47d11ef35bd62dd215887a0aa17426 (diff)
Add some comments to find docker images
Diffstat (limited to '.circleci')
-rw-r--r--.circleci/config.yml11
1 files changed, 11 insertions, 0 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index d95b8d36..7fa9ae05 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -1,7 +1,11 @@
version: 2.0
jobs:
+
+### With all third parties
+
examples:
docker:
+ # cf. https://github.com/GUDHI/gudhi-deploy/blob/main/Dockerfile_for_circleci_image
- image: gudhi/ci_for_gudhi:latest
steps:
- checkout
@@ -95,8 +99,12 @@ jobs:
path: /tmp/doxygen
destination: doxygen
+
+### With all third parties, except CGAL and Eigen
+
examples_without_cgal_eigen:
docker:
+ # cf. https://github.com/GUDHI/gudhi-deploy/blob/main/Dockerfile_for_circleci_image_without_cgal
- image: gudhi/ci_for_gudhi_wo_cgal:latest
steps:
- checkout
@@ -154,6 +162,9 @@ jobs:
python3 setup.py build_ext --inplace
ctest --output-on-failure
+
+### With all third parties, except CGAL
+
examples_without_cgal:
docker:
- image: gudhi/ci_for_gudhi_wo_cgal:latest