summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <vincent.rouvreau@inria.fr>2022-12-14 08:14:42 +0100
committerVincent Rouvreau <vincent.rouvreau@inria.fr>2022-12-14 08:14:42 +0100
commit233de2748377a6ba6fe39712cb9f722dfc352e80 (patch)
treebf0324e25dd2d0db6510a330a2719f38c5272dcc
parent822774766946b45350f445e06cf7c66545bf574c (diff)
wheels are in wheelhouse and not in dist. Use 'python -m build' instead of 'python setup.py bdist_wheel'
-rw-r--r--.github/workflows/pip-build-linux.yml7
-rw-r--r--.github/workflows/pip-build-osx.yml2
-rw-r--r--.github/workflows/pip-build-windows.yml2
-rw-r--r--.github/workflows/pip-packaging-linux.yml12
-rw-r--r--.github/workflows/pip-packaging-osx.yml2
-rw-r--r--.github/workflows/pip-packaging-windows.yml2
6 files changed, 14 insertions, 13 deletions
diff --git a/.github/workflows/pip-build-linux.yml b/.github/workflows/pip-build-linux.yml
index 550a314f..980d610f 100644
--- a/.github/workflows/pip-build-linux.yml
+++ b/.github/workflows/pip-build-linux.yml
@@ -18,16 +18,17 @@ jobs:
cd build_311
cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON311/bin/python ..
cd src/python
- $PYTHON311/bin/python setup.py bdist_wheel
+ $PYTHON311/bin/python -m build
auditwheel show dist/*.whl
auditwheel repair dist/*.whl
+ ls wheelhouse/*.whl
- name: Install and test wheel for Python 3.11
run: |
- $PYTHON311/bin/python -m pip install --user pytest build_311/src/python/dist/*.whl
+ $PYTHON311/bin/python -m pip install --user pytest build_311/src/python/wheelhouse/*.whl
$PYTHON311/bin/python -c "import gudhi; print(gudhi.__version__)"
$PYTHON311/bin/python -m pytest src/python/test/test_alpha_complex.py
- name: Upload linux python wheel
uses: actions/upload-artifact@v3
with:
name: linux python wheel
- path: build_311/src/python/dist/*.whl
+ path: build_311/src/python/wheelhouse/*.whl
diff --git a/.github/workflows/pip-build-osx.yml b/.github/workflows/pip-build-osx.yml
index 573b9766..d1ddf912 100644
--- a/.github/workflows/pip-build-osx.yml
+++ b/.github/workflows/pip-build-osx.yml
@@ -41,7 +41,7 @@ jobs:
cd build
cmake -DCMAKE_BUILD_TYPE=Release -DPython_ADDITIONAL_VERSIONS=3 ..
cd src/python
- python setup.py bdist_wheel
+ python -m build
export PATH="$PATH:`python -m site --user-base`/bin"
delocate-wheel --require-archs universal2 -v dist/*.whl
- name: Install and test python wheel
diff --git a/.github/workflows/pip-build-windows.yml b/.github/workflows/pip-build-windows.yml
index 9d9026c5..c910f781 100644
--- a/.github/workflows/pip-build-windows.yml
+++ b/.github/workflows/pip-build-windows.yml
@@ -36,7 +36,7 @@ jobs:
cd ".\src\python\"
cp "C:\vcpkg\installed\x64-windows\bin\mpfr*.dll" ".\gudhi\"
cp "C:\vcpkg\installed\x64-windows\bin\gmp*.dll" ".\gudhi\"
- python setup.py bdist_wheel
+ python -m build
ls ".\dist\"
cd ".\dist\"
Get-ChildItem *.whl | ForEach-Object{python -m pip install --user $_.Name}
diff --git a/.github/workflows/pip-packaging-linux.yml b/.github/workflows/pip-packaging-linux.yml
index 14b1cf7a..e2cad0e4 100644
--- a/.github/workflows/pip-packaging-linux.yml
+++ b/.github/workflows/pip-packaging-linux.yml
@@ -20,7 +20,7 @@ jobs:
cd build_36
cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON36/bin/python ..
cd src/python
- $PYTHON36/bin/python setup.py bdist_wheel
+ $PYTHON36/bin/python -m build
auditwheel repair dist/*.whl
- name: Install and test wheel for Python 3.6
run: |
@@ -33,7 +33,7 @@ jobs:
cd build_37
cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON37/bin/python ..
cd src/python
- $PYTHON37/bin/python setup.py bdist_wheel
+ $PYTHON37/bin/python -m build
auditwheel repair dist/*.whl
- name: Install and test wheel for Python 3.7
run: |
@@ -46,7 +46,7 @@ jobs:
cd build_38
cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON38/bin/python ..
cd src/python
- $PYTHON38/bin/python setup.py bdist_wheel
+ $PYTHON38/bin/python -m build
auditwheel repair dist/*.whl
- name: Install and test wheel for Python 3.8
run: |
@@ -59,7 +59,7 @@ jobs:
cd build_39
cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON39/bin/python ..
cd src/python
- $PYTHON39/bin/python setup.py bdist_wheel
+ $PYTHON39/bin/python -m build
auditwheel repair dist/*.whl
- name: Install and test wheel for Python 3.9
run: |
@@ -72,7 +72,7 @@ jobs:
cd build_310
cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON310/bin/python ..
cd src/python
- $PYTHON310/bin/python setup.py bdist_wheel
+ $PYTHON310/bin/python -m build
auditwheel repair dist/*.whl
- name: Install and test wheel for Python 3.10
run: |
@@ -85,7 +85,7 @@ jobs:
cd build_311
cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON311/bin/python ..
cd src/python
- $PYTHON311/bin/python setup.py bdist_wheel
+ $PYTHON311/bin/python -m build
auditwheel repair dist/*.whl
- name: Install and test wheel for Python 3.11
run: |
diff --git a/.github/workflows/pip-packaging-osx.yml b/.github/workflows/pip-packaging-osx.yml
index 9ddbcfce..639580b8 100644
--- a/.github/workflows/pip-packaging-osx.yml
+++ b/.github/workflows/pip-packaging-osx.yml
@@ -43,7 +43,7 @@ jobs:
cd build
cmake -DCMAKE_BUILD_TYPE=Release -DPython_ADDITIONAL_VERSIONS=3 ..
cd src/python
- python setup.py bdist_wheel
+ python -m build
- name: Install and test python wheel
run: |
python -m pip install --user pytest build/src/python/dist/*.whl
diff --git a/.github/workflows/pip-packaging-windows.yml b/.github/workflows/pip-packaging-windows.yml
index df0db9a5..29c65138 100644
--- a/.github/workflows/pip-packaging-windows.yml
+++ b/.github/workflows/pip-packaging-windows.yml
@@ -39,7 +39,7 @@ jobs:
cd ".\src\python\"
cp "C:\vcpkg\installed\x64-windows\bin\mpfr*.dll" ".\gudhi\"
cp "C:\vcpkg\installed\x64-windows\bin\gmp*.dll" ".\gudhi\"
- python setup.py bdist_wheel
+ python -m build
ls ".\dist\"
cd ".\dist\"
Get-ChildItem *.whl | ForEach-Object{python -m pip install --user $_.Name}