summaryrefslogtreecommitdiff
path: root/data
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-03-02 15:07:38 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-03-02 15:07:38 +0000
commit480a4df6fc9e3d1086039735f1625fbc2d5dca0e (patch)
tree9ebc64174dfec884ca1c3719644be8252754bf74 /data
parented4440e6d41d957fe567b2e0d0b06ba39fb1906e (diff)
Add of hyper sphere and cube generator of OFF files.
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alphashapes@473 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 894167c2f2ab6e9f209b35adb8d362b09c6eeec5
Diffstat (limited to 'data')
-rw-r--r--data/points/generator/CMakeLists.txt21
-rw-r--r--data/points/generator/README26
-rw-r--r--data/points/generator/hypergenerator.cpp129
3 files changed, 176 insertions, 0 deletions
diff --git a/data/points/generator/CMakeLists.txt b/data/points/generator/CMakeLists.txt
new file mode 100644
index 00000000..42f3e3ee
--- /dev/null
+++ b/data/points/generator/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHIPointsGenerator)
+
+if(CGAL_FOUND)
+ include( ${CGAL_USE_FILE} )
+
+ find_package(Eigen3 3.1.0)
+ if (EIGEN3_FOUND)
+ include( ${EIGEN3_USE_FILE} )
+ include_directories (BEFORE "../../include")
+
+ add_executable ( hypergenerator hypergenerator.cpp )
+ add_test(hypergenerator_on_sphere_3000_10_5.0 ${CMAKE_CURRENT_BINARY_DIR}/hypergenerator on sphere onSphere.off 3000 10 5.0)
+ add_test(hypergenerator_on_sphere_10000_3 ${CMAKE_CURRENT_BINARY_DIR}/hypergenerator on sphere onSphere.off 10000 3)
+ add_test(hypergenerator_in_sphere_7000_12_10.8 ${CMAKE_CURRENT_BINARY_DIR}/hypergenerator in sphere inSphere.off 7000 12 10.8)
+ add_test(hypergenerator_in_sphere_50000_2 ${CMAKE_CURRENT_BINARY_DIR}/hypergenerator in sphere inSphere.off 50000 2)
+ # on cube is not available in CGAL
+ add_test(hypergenerator_in_cube_7000_12_10.8 ${CMAKE_CURRENT_BINARY_DIR}/hypergenerator in cube inCube.off 7000 12 10.8)
+ add_test(hypergenerator_in_cube_50000_2 ${CMAKE_CURRENT_BINARY_DIR}/hypergenerator in cube inCube.off 50000 2)
+ endif()
+endif()
diff --git a/data/points/generator/README b/data/points/generator/README
new file mode 100644
index 00000000..e6b28eb0
--- /dev/null
+++ b/data/points/generator/README
@@ -0,0 +1,26 @@
+To build the example, run in a Terminal:
+
+cd /path-to-gudhi/
+cmake .
+cd /path-to-data-generator/
+make
+
+
+Example of use :
+
+*** Hyper sphere|cube generator
+
+./hypergenerator on sphere onSphere.off 1000 3 15.2
+
+ => generates a onSphere.off file with 1000 points randomized on a sphere of dimension 3 and radius 15.2
+
+./hypergenerator in sphere inSphere.off 100 2
+
+ => generates a inSphere.off file with 100 points randomized in a sphere of dimension 2 (circle) and radius 1.0 (default)
+
+./hypergenerator in cube inCube.off 10000 3 5.8
+
+ => generates a inCube.off file with 10000 points randomized in a cube of dimension 3 and side 5.8
+
+!! Warning: hypegenerator on cube is not available !!
+
diff --git a/data/points/generator/hypergenerator.cpp b/data/points/generator/hypergenerator.cpp
new file mode 100644
index 00000000..f4ea6b07
--- /dev/null
+++ b/data/points/generator/hypergenerator.cpp
@@ -0,0 +1,129 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Vincent Rouvreau
+ *
+ * Copyright (C) 2014 INRIA Saclay (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <CGAL/Epick_d.h>
+#include <CGAL/point_generators_d.h>
+#include <CGAL/algorithm.h>
+#include <CGAL/assertions.h>
+
+#include <iostream>
+#include <iterator>
+#include <vector>
+#include <fstream> // for std::ofstream
+
+
+typedef CGAL::Epick_d< CGAL::Dynamic_dimension_tag > K;
+typedef K::Point_d Point;
+
+void usage(char * const progName) {
+ std::cerr << "Usage: " << progName << " in|on sphere|cube off_file_name points_number[integer > 0] dimension[integer > 1] radius[double > 0.0 | default = 1.0]" << std::endl;
+ exit(-1); // ----- >>
+}
+
+int main(int argc, char **argv) {
+ // program args management
+ if ((argc != 6) && (argc != 7)) {
+ std::cerr << "Error: Number of arguments (" << argc << ") is not correct" << std::endl;
+ usage(argv[0]);
+ }
+
+ int points_number = 0;
+ int returnedScanValue = sscanf(argv[4], "%d", &points_number);
+ if ((returnedScanValue == EOF) || (points_number <= 0)) {
+ std::cerr << "Error: " << argv[4] << " is not correct" << std::endl;
+ usage(argv[0]);
+ }
+
+ int dimension = 0;
+ returnedScanValue = sscanf(argv[5], "%d", &dimension);
+ if ((returnedScanValue == EOF) || (dimension <= 0)) {
+ std::cerr << "Error: " << argv[5] << " is not correct" << std::endl;
+ usage(argv[0]);
+ }
+
+ double radius = 1.0;
+ if (argc == 7) {
+ returnedScanValue = sscanf(argv[6], "%lf", &radius);
+ if ((returnedScanValue == EOF) || (radius <= 0.0)) {
+ std::cerr << "Error: " << argv[6] << " is not correct" << std::endl;
+ usage(argv[0]);
+ }
+ }
+
+ bool in = false;
+ if (strcmp(argv[1], "in") == 0) {
+ in = true;
+ } else if (strcmp(argv[1], "on") != 0) {
+ std::cerr << "Error: " << argv[1] << " is not correct" << std::endl;
+ usage(argv[0]);
+ }
+
+ bool sphere = false;
+ if (memcmp(argv[2], "sphere", sizeof("sphere")) == 0) {
+ sphere = true;
+ } else if (memcmp(argv[2], "cube", sizeof("cube")) != 0) {
+ std::cerr << "Error: " << argv[2] << " is not correct" << std::endl;
+ usage(argv[0]);
+ }
+
+ std::ofstream diagram_out(argv[3]);
+ diagram_out << "OFF" << std::endl;
+ diagram_out << points_number << " 0 0" << std::endl;
+
+ if (diagram_out.is_open()) {
+ // Instanciate a random point generator
+ CGAL::Random rng(0);
+ // Generate "points_number" random points in a vector
+ std::vector<Point> points;
+ if (in) {
+ if (sphere) {
+ CGAL::Random_points_in_ball_d<Point> rand_it(dimension, radius, rng);
+ CGAL::cpp11::copy_n(rand_it, points_number, std::back_inserter(points));
+ } else {
+ CGAL::Random_points_in_cube_d<Point> rand_it(dimension, radius, rng);
+ CGAL::cpp11::copy_n(rand_it, points_number, std::back_inserter(points));
+ }
+ } else { // means "on"
+ if (sphere) {
+ CGAL::Random_points_on_sphere_d<Point> rand_it(dimension, radius, rng);
+ CGAL::cpp11::copy_n(rand_it, points_number, std::back_inserter(points));
+ } else {
+ std::cerr << "Sorry: on cube is not available" << std::endl;
+ usage(argv[0]);
+ }
+ }
+
+ for (auto thePoint : points) {
+ int i = 0;
+ for (;i < dimension - 1; i++) {
+ diagram_out << thePoint[i] << " ";
+ }
+ diagram_out << thePoint[i] << std::endl; // last point + Carriage Return
+ }
+ } else {
+ std::cerr << "Error: " << argv[3] << " cannot be opened" << std::endl;
+ usage(argv[0]);
+ }
+
+ return 0;
+}
+