summaryrefslogtreecommitdiff
path: root/src/cmake/modules/GUDHI_compilation_flags.cmake
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2023-01-20 13:47:30 +0100
committerGard Spreemann <gspr@nonempty.org>2023-01-20 13:47:30 +0100
commit688cbc5c29d0a6aaf233eee185a06cef5cb2e745 (patch)
treecb13b84e9f7cddea48b903d24014f63d1dfda7e3 /src/cmake/modules/GUDHI_compilation_flags.cmake
parent2b3caf86fc6500a9fca9e9085012a2315fbbac3b (diff)
parented492f09ca3c9d7cd972bbbbec37f680cd624fbe (diff)
Merge tag 'tags/gudhi-release-3.7.1' into dfsg/latestdfsg/latest
Diffstat (limited to 'src/cmake/modules/GUDHI_compilation_flags.cmake')
-rw-r--r--src/cmake/modules/GUDHI_compilation_flags.cmake3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/cmake/modules/GUDHI_compilation_flags.cmake b/src/cmake/modules/GUDHI_compilation_flags.cmake
index 567fbc40..b43ccf73 100644
--- a/src/cmake/modules/GUDHI_compilation_flags.cmake
+++ b/src/cmake/modules/GUDHI_compilation_flags.cmake
@@ -11,7 +11,8 @@ macro(add_cxx_compiler_flag _flag)
endif()
endmacro()
-set (CMAKE_CXX_STANDARD 14)
+set (CMAKE_CXX_STANDARD 17)
+# This number needs to be changed in python/CMakeLists.txt at the same time
enable_testing()