summaryrefslogtreecommitdiff
path: root/.circleci
diff options
context:
space:
mode:
Diffstat (limited to '.circleci')
-rw-r--r--.circleci/config.yml18
1 files changed, 18 insertions, 0 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index f6a875dd..85e42f8a 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -77,6 +77,23 @@ jobs:
path: /tmp/htmlcov
destination: htmlcov
+ python_tests_with_network:
+ docker:
+ - image: gudhi/ci_for_gudhi:latest
+ steps:
+ - checkout
+ - run:
+ name: Build and test python module with network
+ command: |
+ git submodule init
+ git submodule update
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 -DWITH_GUDHI_TEST=ON -DWITH_NETWORK=ON ..
+ cd src/python
+ python3 setup.py build_ext --inplace
+ ctest --output-on-failure
+
doxygen:
docker:
- image: gudhi/ci_for_gudhi:latest
@@ -245,4 +262,5 @@ workflows:
- tests
- utils
- python
+ - python_tests_with_network
- doxygen