summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Alpha_complex/test/CMakeLists.txt')
-rw-r--r--src/Alpha_complex/test/CMakeLists.txt20
1 files changed, 16 insertions, 4 deletions
diff --git a/src/Alpha_complex/test/CMakeLists.txt b/src/Alpha_complex/test/CMakeLists.txt
index dd2c235f..7838a15d 100644
--- a/src/Alpha_complex/test/CMakeLists.txt
+++ b/src/Alpha_complex/test/CMakeLists.txt
@@ -10,17 +10,29 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
target_link_libraries(Alpha_complex_test_unit ${CGAL_LIBRARY})
add_executable ( Alpha_complex_dim3_test_unit Alpha_complex_dim3_unit_test.cpp )
target_link_libraries(Alpha_complex_dim3_test_unit ${CGAL_LIBRARY})
- add_executable ( Delaunay_complex_test_unit Delaunay_complex_unit_test.cpp )
- target_link_libraries(Delaunay_complex_test_unit ${CGAL_LIBRARY})
+ add_executable ( Delaunay_complex_Epeck_dynamic_test_unit Delaunay_complex_Epeck_dynamic_unit_test.cpp )
+ target_link_libraries(Delaunay_complex_Epeck_dynamic_test_unit ${CGAL_LIBRARY})
+ add_executable ( Delaunay_complex_Epeck_static_test_unit Delaunay_complex_Epeck_static_unit_test.cpp )
+ target_link_libraries(Delaunay_complex_Epeck_static_test_unit ${CGAL_LIBRARY})
+ add_executable ( Delaunay_complex_Epick_dynamic_test_unit Delaunay_complex_Epick_dynamic_unit_test.cpp )
+ target_link_libraries(Delaunay_complex_Epick_dynamic_test_unit ${CGAL_LIBRARY})
+ add_executable ( Delaunay_complex_Epick_static_test_unit Delaunay_complex_Epick_static_unit_test.cpp )
+ target_link_libraries(Delaunay_complex_Epick_static_test_unit ${CGAL_LIBRARY})
if (TBB_FOUND)
target_link_libraries(Alpha_complex_test_unit ${TBB_LIBRARIES})
target_link_libraries(Alpha_complex_dim3_test_unit ${TBB_LIBRARIES})
- target_link_libraries(Delaunay_complex_test_unit ${TBB_LIBRARIES})
+ target_link_libraries(Delaunay_complex_Epeck_dynamic_test_unit ${TBB_LIBRARIES})
+ target_link_libraries(Delaunay_complex_Epeck_static_test_unit ${TBB_LIBRARIES})
+ target_link_libraries(Delaunay_complex_Epick_dynamic_test_unit ${TBB_LIBRARIES})
+ target_link_libraries(Delaunay_complex_Epick_static_test_unit ${TBB_LIBRARIES})
endif()
gudhi_add_boost_test(Alpha_complex_test_unit)
gudhi_add_boost_test(Alpha_complex_dim3_test_unit)
- gudhi_add_boost_test(Delaunay_complex_test_unit)
+ gudhi_add_boost_test(Delaunay_complex_Epeck_dynamic_test_unit)
+ gudhi_add_boost_test(Delaunay_complex_Epeck_static_test_unit)
+ gudhi_add_boost_test(Delaunay_complex_Epick_dynamic_test_unit)
+ gudhi_add_boost_test(Delaunay_complex_Epick_static_test_unit)
endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)