summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authorBryn Keller <xoltar@xoltar.org>2016-05-02 11:50:31 -0700
committerBryn Keller <xoltar@xoltar.org>2016-05-02 11:50:31 -0700
commit83e49c569c2b53a7068f42df616ed8ee695a0fb8 (patch)
tree5cc45ee59aeeb39eeb9d400becd3a01eb0be5045 /python/setup.py
parent57040bdfa4d7c022d8887420a7dda6c550b84858 (diff)
Added readme section on installation, removed code that blocked execution under 2.7. Still needs work to build on desired platforms
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/python/setup.py b/python/setup.py
index 5e71cc7..2c6d65d 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -2,6 +2,7 @@ from setuptools import setup, Extension, find_packages
from setuptools.command.build_ext import build_ext
import sys
import os.path
+
ext_modules = [
Extension(
'_phat',
@@ -14,7 +15,7 @@ ext_modules = [
here = os.path.abspath(os.path.dirname(__file__))
# Get the long description from the README file
-with open(os.path.join(here, 'README.rst'), encoding='utf-8') as f:
+with open(os.path.join(here, 'README.rst')) as f:
long_description = f.read()
class BuildExt(build_ext):