summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/python-package.yml4
1 files changed, 4 insertions, 0 deletions
diff --git a/.github/workflows/python-package.yml b/.github/workflows/python-package.yml
index 605a31e..80b7ba3 100644
--- a/.github/workflows/python-package.yml
+++ b/.github/workflows/python-package.yml
@@ -34,6 +34,9 @@ jobs:
python -m pip install flake8 pytest nose numpy scipy
python -m pip install -q cython
if [ -f requirements.txt ]; then pip install -r requirements.txt; fi
+ - name: Install package
+ run: |
+ python setup.py build_ext --inplace
# - name: Lint with flake8
# run: |
# # stop the build if there are Python syntax errors or undefined names
@@ -43,3 +46,4 @@ jobs:
- name: Test with nosetest
run: |
nosetests
+ nosetests test/numeric