summaryrefslogtreecommitdiff
path: root/wasserstein/example/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2022-04-29 13:54:09 +0200
committerGard Spreemann <gspr@nonempty.org>2022-04-29 13:54:09 +0200
commitfb4866e1d827389db17d74e5986d848617c8ef72 (patch)
tree46093502435ec117b137991a51acbe7f67b41dbc /wasserstein/example/CMakeLists.txt
parent66702d9cf122703964dbe22319ae8d97424d496f (diff)
parent8fbae1d789b3c9d7e9b079284c85489d8dcd7e65 (diff)
Merge tag 'v1.0.0' into dfsg/latestdfsg/latest
Version 1.0.0
Diffstat (limited to 'wasserstein/example/CMakeLists.txt')
-rw-r--r--wasserstein/example/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/wasserstein/example/CMakeLists.txt b/wasserstein/example/CMakeLists.txt
new file mode 100644
index 0000000..2e2f1f2
--- /dev/null
+++ b/wasserstein/example/CMakeLists.txt
@@ -0,0 +1,21 @@
+add_executable(wasserstein_dist wasserstein_dist.cpp)
+target_link_libraries(wasserstein_dist PUBLIC ${libraries})
+
+add_executable(wasserstein_dist_dipha wasserstein_dist_dipha.cpp)
+target_link_libraries(wasserstein_dist_dipha PUBLIC ${libraries})
+
+# pure geometric version, arbitrary dimension
+add_executable(wasserstein_dist_point_cloud wasserstein_dist_point_cloud.cpp)
+target_link_libraries(wasserstein_dist_point_cloud PUBLIC ${libraries})
+
+if(MSVC)
+ target_compile_options(wasserstein_dist PRIVATE /W4 /WX)
+ target_compile_options(wasserstein_dist_dipha PRIVATE /W4 /WX)
+ target_compile_options(wasserstein_dist_point_cloud PRIVATE /W4 /WX)
+else()
+ target_compile_options(wasserstein_dist PRIVATE -Wall -Wextra -Wpedantic)
+ target_compile_options(wasserstein_dist_dipha PRIVATE -Wall -Wextra -Wpedantic)
+ target_compile_options(wasserstein_dist_point_cloud PRIVATE -Wall -Wextra -Wpedantic)
+endif()
+
+